Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
new guy !!
Hello to all, I just purchased my first wing 85 LTD...What a great bike.
Having a few things it needs, I began surching out for info on the web..
WoW!! what luck to find so much great info and people that know and love these bikes. Big Grin I have started trying to figure out some of the issue's
my bike has and I'm planning alot of questions soon. If anyone has any advice or suggestions ,It will be greatly appreciated for im new to this bike. THANKS Dave
Reply
#1 06-21-2007, 07:22 PM,
welcome Dave
you've come to the right place! the guys here are a terrific bunch and you just got a terrific bike. wish I had the LTD, they have just a touch more class in my humble opinion. :wink:

let the questions roll, [Image: banana.gif]
John McFarland
Chapter Director
GWRRA FL2-W
member 367388
Reply
#2 06-21-2007, 07:40 PM,
Welcome to th forum from Ont.,Canada
Never road a fuel inj. 1200 but after reading the info here I wish I had the chance somewhere along the way.
Fatwing Chris
If Id'a known it would last this long I would've taken better care of it !!!
[Image: NewBabyPicsSpring024SmallCustom-1.jpg]
Reply
#3 06-21-2007, 07:51 PM,
Welcome aboard, Dave. I'm sure you'll find all the help you need here on this forum. I know the members have certainly helped me a lot.
Reply
#4 06-21-2007, 08:09 PM,
Hello and welcome Dave. I'm hoping that you have both the regular and the suplemental manual for your bike. One of the first things I would do is clean the throttle bodies with carb cleaner. If dirty they can really can cause some strange drivability problems. If you need to know the process just let me know.
Ed (Vic) Belanger - 1954-2015
Founder of gl1200goldwings.com

Reply
#5 06-21-2007, 08:36 PM,
Welcome Dave, I hope you enjoy this great Forum.
Ride safe have fun and enjoy. Lane
1985 Aspencade
2002 Vulcan
Reply
#6 06-22-2007, 12:12 AM,
Hello Dave,..I also recently joined this Forum, This is a great Bunch of Wing owners .
In the short time I have had my 85Ltd they have given me some great info ,both by responding to my questions and by reading the other threads here.
Jim
1985 Ltd.
Reply
#7 06-28-2007, 10:12 PM,
Best forum for quality post's and help with issues at ANY level.
Reply
#8 06-28-2007, 10:48 PM,
Welcome aboard!!
Reply
#9 06-28-2007, 11:20 PM,
welcome, this is a great place to be.
Robbie
1986 GL1200 Aspencade (mariah)
Reply
#10 06-29-2007, 04:55 AM,
welcome modog!
Reply
#11 06-29-2007, 04:40 PM,
Thanks to all for the kind introductions,I have read alot already on this site that has helped me a great deal.....I have taken out the burn't up 3 pin connector.checked the grounds all over the bike and they all show good on the meter..I have road it some and seem's to show about 13.5v so i'm hoping I have no charging problems coming at me....The engine runs good down the road,the shifting is kinda noisy?? The speedo was kinda going crazy and i found a bad connection where it plugs in on the left side of fairing.Im not sure what that box right there is ?maybe someone could let me kow....I played with it and it seems to work constant now...one big deal now is the CRUISE Cont.. not working and I have read all over this site and found nothing about a LTD factory cruise
maybe someone could give some ideas on this one??Im not a bike mechanic ....but I do about everything else..I did check the clutch switches shows to be good the pedal lights up rear brake light but not the lever.Not realy sure if this is anything to try look into for the cruise???
if the lights not on it shouldnt be showing depressed?? I would like to get cruise working on this bike so some idea's or any thoughts would be a big help..
Reply
#12 07-04-2007, 11:36 PM,
For the clunky shifting most of it is in learning how to shift properly. You have to let off the gas fully when upshifting and press firmly on the shifter. Shifting gently just makes noise. When donwshifting raise the RPM's a bit.

Also, flush the clutch fluid then bleed it and bleed it at the banjo bolt as well.

For the cruise the switches on both brakes, if they are out of adjustment they coul'd stop it from working. Also make sure the fuse is good.
Ed (Vic) Belanger - 1954-2015
Founder of gl1200goldwings.com

Reply
#13 07-05-2007, 08:24 AM,


Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | GL1200 GOLDWINGS | Return to Top | | Lite (Archive) Mode | RSS Syndication
google-site-verification: googled4b4fe31e07b65d8.html