GL1200 GOLDWINGS
Stock Radio Acting Weird - Printable Version

+- GL1200 GOLDWINGS (http://www.gl1200goldwings.com/gl1200)
+-- Forum: TECH CENTER (http://www.gl1200goldwings.com/gl1200/forumdisplay.php?fid=39)
+--- Forum: RADIO, CB, SOUND SYSTEM (http://www.gl1200goldwings.com/gl1200/forumdisplay.php?fid=19)
+--- Thread: Stock Radio Acting Weird (/showthread.php?tid=3626)



Stock Radio Acting Weird - Guest - 10-19-2008

I have a 87 aspy with a stock panasonic radio. When I purchased it the owner told me that the FM wasn't working but the AM did? I turned on the bike and radio and what you know, the FM was working...I've had the bike since May and the radio has been working fine until last week...then suddenly static on FM...AM works fine. A few minutes ago after looking for similiar issues on our forum, I went out and turned on the radio and again static...but suddenly it stopped and the FM is now working???

Any ideas or suggestions

Mike


Re: Stock Radio Acting Weird - Guest - 10-19-2008

Possibly dirty contacts. After 21 years things do get dirty. Try getting some electrical contact cleaner and spraying the controls.


Re: Stock Radio Acting Weird - Guest - 10-20-2008

Ok, are you talking about the outside controls and/or the contacts behind the radio or both?


Re: Stock Radio Acting Weird - Guest - 10-20-2008

Mainly the controls. (volume, tone etc) Only problem is I'm not sure if you would have to take the unit out to get access. I used to play in a band years ago and I was forever having to clean the controls because of static.


Re: Stock Radio Acting Weird - Guest - 10-20-2008

Ok, I'll try that thanks